News: Putting FUN and FRIENDLINESS, FIRST into owning and learning about AMC small bodied cars, primarily Eagles, Spirits and Concords as well as vehicles built in AMC's Mexican subsidiary, VAM.

The AMC Eaglepedia can now be accessed using the buttons found below  This is a comprehensive ever growing archive of information, tips, diagrams, manuals, etc. for the AMC Eagle and other small bodied AMC cars. 

Also a button is now available for our Face Book Group page.


Welcome to the AMC Eagles Nest.  A new site under "old" management -- so welcome to your new home for everything related to AMC Eagles, Spirits and Concords along with opportunities to interact with other AMC'ers.  This site will soon be evolving to look different than it has and we will be incorporating new features we hope you will find useful, entertaining and expand your AMC horizons.

You can now promote your topics at your favorite social media site by clicking on the appropriate icon (top upper right of the page) while viewing the topic you wish to promote.


  • June 27, 2022, 06:55:07 AM

Login with username, password and session length

Author Topic: TBI Upgrade Exhaust Air Injection Plug Issue  (Read 3452 times)

0 Members and 1 Guest are viewing this topic.

Offline Beaverseagle

  • Eagle
  • **
  • Posts: 107
  • Thumbs Up 5
TBI Upgrade Exhaust Air Injection Plug Issue
« on: August 23, 2016, 10:12:11 PM »
This is for the TBI Guys,

Hunting down vacuum leaks for my TBI upgrade. She's running very rich. I removed the air injection system from my exhaust manifold and plugged the holes. She starts but dies once warm. And won't start again.  Any clue what could be going on? She started and ran before but bogged at WOT because if the bad mixture.

Thanks!
82 SX4 258 w/ 2 inch lift 235 tires and TBI kit.

Online amcfool1

  • Eagle Limited
  • *****
  • Posts: 600
  • Thumbs Up 30
Re: TBI Upgrade Exhaust Air Injection Plug Issue
« Reply #1 on: August 23, 2016, 11:33:18 PM »
hi, I don't have TBI, but isn't it supposed to self adjust the mixture via inputs from sensors, mainly the O2 sensor? Is your oxygen sensor hooked up and working? good luck, gz

Offline Beaverseagle

  • Eagle
  • **
  • Posts: 107
  • Thumbs Up 5
Re: TBI Upgrade Exhaust Air Injection Plug Issue
« Reply #2 on: August 24, 2016, 11:27:03 AM »
Yes the O2 sensor is hooked up and was working just fine.  I played with the timing but still nothing. I'm thinking I may need to adjust my IAC and TPS sensor if the mixture has change significantly.
82 SX4 258 w/ 2 inch lift 235 tires and TBI kit.

Offline mo.eagles

  • Eagle DL
  • ***
  • Posts: 240
  • Thumbs Up 13
Re: TBI Upgrade Exhaust Air Injection Plug Issue
« Reply #3 on: August 26, 2016, 07:40:30 PM »
Do you have a plugged cat ?
'85 wagon Limited   tilt wheel , cruise control
power seats ,windows and locks
rear window washer /wiper 
tach and gauge package
A/C
 '85 wagon   power windows and locks
rear window washer/wiper
factory tow package
A/C

Offline Beaverseagle

  • Eagle
  • **
  • Posts: 107
  • Thumbs Up 5
Re: TBI Upgrade Exhaust Air Injection Plug Issue
« Reply #4 on: August 27, 2016, 10:58:49 AM »
I don't think so. She was running not great but she had plenty of exhaust coming out.
82 SX4 258 w/ 2 inch lift 235 tires and TBI kit.

Offline Beaverseagle

  • Eagle
  • **
  • Posts: 107
  • Thumbs Up 5
Re: TBI Upgrade Exhaust Air Injection Plug Issue
« Reply #5 on: August 29, 2016, 07:13:32 PM »
Bingo. Dropped the cat. It was completely plugged. How was it even runnin? The emission system does more harm than good. It bipassed the exhaust system.  Thanks for the help!
82 SX4 258 w/ 2 inch lift 235 tires and TBI kit.

 

SMF spam blocked by CleanTalk