mail

Author Topic: Alternator, going, going, ...  (Read 100 times)

0 Members and 1 Guest are viewing this topic.

Offline Canoe

  • Eagle Sundaancer
  • ******
  • Posts: 1060
  • Thumbs Up 48
Alternator, going, going, ...
« on: November 10, 2020, 12:36:37 PM »
I've had issues for a few months with battery discharging and low headlight intensity.
  • Alternator is a 12SI, clocked at 3, but I don't remember if it is the 94 or 78 amp version.
  • The battery idiot light on the instrument cluster would come on dim for a period of time while driving. Headlights and even the instrument lights would have lower intensity during this, and turn signal would blink really slowly. 
  • The battery, new this summer, was discharging overnight, typically so low no cluster lights. The ignition switch was leaving ACC on after the car was shut off and key removed. I had to start being very careful to play with the key in the switch after shutting the engine off to ensure ACC was also shut off. Power at the cigarette lighter socket or the instrument cluster showing the clock off seemed to be the key. 
  • Then recently I also had occasional nights where the battery would discharge overnight anyways.
    I found one online reference of something new to me: that when the diodes in the AC to DC bridge rectifiers start to go, the alternator can drain the battery overnight. I don't know if that is possible/true.
  • Some nights ago, the battery idiot light started coming on full for a portion of a drive. Lights really dim during these periods. There was no predicting if it would or wouldn't be able to re-start following that, so I had to leave the engine running until I got home.
  • To get around that nonsense, to be able to self-boost I started carrying my RV deep cycle battery around with me. Some times the Eagle's battery is so discharged that I need to let the jumpered batteries sit for some minutes to bring the Eagle's battery charge/voltage up enough so it's not pulling the voltage down, before I'm able to turn the starter over.
    One of those small LiIon boost packs would sure be handy...
  • I did the standard simple charging/alternator-output voltage test: fully charge of the battery with an external charger, then measure its engine-off voltage (12.65 VDC) and then the voltage when the engine running to get the voltage presented to the battery by the alternator (14.4 VDC). Those voltages look normal.
    Sure wish I had a voltage gauge to see what the voltage was doing when the idiot light turns on...
  • Twice during this, I checked all of the connections for battery, solenoid and alternator. No issues found.
  • Engine power has not been a problem, nor any power drop discernible. (Still adjusting to having an Eagle that will accelerate going up a steep hill...) But I have the upgrade to the GM ignition module so the upgraded high-voltage ignition coil is presented with full positive voltage with current limiting by the ignition module with low-side current sensing (well, "below" the coil; while likely low-side, I don't know if the sense resistor is low-side or high-side within the IM).
  • With all of the above, I figure the alternator is going bad.
    Ordered a reman, 12SI 78 amp clocked 3. (space for a 3 or 9 clock)
  • Last night while driving, the idiot light came full on, and then I also noticed a very distinct static/hum noise (at or beyond the center dash) - an indicator that one or more of the rectifier diodes isn't working and the alternator is leaking VAC onto its VDC output.
    - When I stopped, the idiot light was off and that noise gone, so I didn't get to use my multimeter on VAC to check for leaking VAC presented to the battery.
    - No sign yet that any VAC fried anything. But with no measure of VAC, VAC is not confirmed nor do I know its voltage to know that risk.

Offline Taylor

  • Administrator
  • Eagle Sport
  • ******
  • Posts: 349
  • Thumbs Up 17
Re: Alternator, going, going, ...
« Reply #1 on: November 18, 2020, 08:50:33 PM »
I had a similar problem. Slowly the battery light started to glow. After a couple days it was full on bright. I bought a alternator rebuild kit, probably about 9-10 years ago. Just because I figured it was the original alternator, and I might need to fix or replace. Having never rebuilt a alternator before I was a bit hesitant.
The new parts worked great. Forget where I got it. Might have been rockauto.com
The only problem I had was getting the brushes to stay out of the way when reinstalling the stator/winding. There was a tiny little hole on the back that was just big enough to put a sewing needle through, that would hold the brush out of the way.
Hope you have had good luck with the repairs.
2010 Toyota Rav4 Daily Driver (better mileage)
1985 AMC Eagle Limited wagon 🖖🏼🦅
2005 Ford Excursion 4X4 wife's around town daily driver.

 

SMF spam blocked by CleanTalk