Choose style:

Author Topic: Frustrated already!  (Read 1455 times)

0 Members and 1 Guest are viewing this topic.

Offline overtonmike

  • Eagle
  • **
  • Posts: 15
  • Thumbs Up 1
Frustrated already!
« on: April 30, 2012, 07:42:34 PM »
Hi all,
 :newbie:
Newbie here and unfortunately my first post is a cry for help. I recently purchased a 1984 wagon. The previous owners took pretty good care of it. All that seemed to be wrong with it was the auto trans was slipping. I took it to someone reputable and had it rebuilt (the transmission). Since then it has been great. Passed emmisions with flying colors. My 16 year old daughter has been driving it to school. Of course she hates it! But her wise father knows that later in her life she will appreciate the experience ;D
Now on to the recent problem. Out of the blue it started dying on her. I wish I would have been there when it started but I wasn't. I was able to limp it home with her behind me. She said that it was pouring black smoke out the exhast as we neared home. Next morning it started and ran fine for about a minute and then it started sputtering and died. I'm not much of a mechanic but I have replaced the basic electrical stuff including plugs, wires, distributor cap, rotor, coil and ICM thinking that it was one of these items. Nope it still does the same thing. What do I check now? Any ideas?
thank you all

Prafeston

  • Guest
Re: Frustrated already!
« Reply #1 on: April 30, 2012, 08:16:13 PM »
...and then throw them all away and by GRONK's Motorcraft carb! :)

Online AMC of Houston

  • The only thing we learn from history is that we don't learn from history.
  • Global Moderator
  • Eagle Limited
  • *****
  • Posts: 525
  • Thumbs Up 62
    • American Motors Club of Houston
Re: Frustrated already!
« Reply #2 on: April 30, 2012, 09:46:10 PM »
Well, depends on where he lives.   Some areas STILL check for original smog equipment, rather than just check the tailpipe emissions (why is beyond me; but I'm not a bureaucrat!!).

Just about has to be a carb issue due to the "black smoke" comment.   Something stuck on the needle/seat, or plugged bleed idle tubes, or both!!
George G.
'81 Eagle Sundancer
'85 Eagle Waggie
1960 1902 Rambler Replica
'64 American
'70 AMX (Big Bad Blue), '70 AMX (White)
'77 Gremlin
'78 Pacer Coupe, '78 Pacer Wagon
'79 Pacer Wagon
'73 Jensen Interceptor
'86 Audi 5000 Turbo
'98 Aston Martin DB7
'09 Nissan Titan
'10 Nissan Maxima

Offline overtonmike

  • Eagle
  • **
  • Posts: 15
  • Thumbs Up 1
Re: Frustrated already!
« Reply #3 on: April 30, 2012, 10:24:43 PM »
I am very interested in throwing away all the vacuum lines. Where do I get the Motorcraft carb? I'm not too worried about the smog equipment.

Prafeston

  • Guest

Offline overtonmike

  • Eagle
  • **
  • Posts: 15
  • Thumbs Up 1
Re: Frustrated already!
« Reply #5 on: April 30, 2012, 11:30:13 PM »
Thanks for that. I've read through that thread and I'm ready to get one. I hope that takes care of this mess I'm in. I think it will!

Offline overtonmike

  • Eagle
  • **
  • Posts: 15
  • Thumbs Up 1
Re: Frustrated already!
« Reply #6 on: May 01, 2012, 05:12:24 PM »
Just ordered the kit from Gronk!! Of course I'm excited!!

Prafeston

  • Guest
Re: Frustrated already!
« Reply #7 on: May 01, 2012, 05:30:15 PM »
Good deal. One of the best things you can do for your rough running old Eagle! :) There are plenty of threads that should help you through the install as well as the instructions aren't specifically written for the Eagle, but for a Jeep.

 

Page created in 0.044 seconds with 21 queries.